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1 Introduction  

PepSlide® Analyzer (PSA) supports microarray data analysis and is particularly suited for peptide 

arrays and peptide microarrays. In addition, the software provides statistical data mining tools for 

discovering parameters influencing the study and their relation. 

Furthermore, PSA facilitates analysis of peptide libraries. The software can refer the quantified data 

to the peptide library design and the intended application, thus it is able to provide meaningful 

information with respect to the application. If e.g. a target protein or antigen is translated into 

overlapping peptides for epitope mapping, PSA can suggest a grouped list of peptides which 

represent an epitope or consensus motif of an antibody or serum sample. 

PSA is part of the PepSlide® software suite. The other program is PepSlide® Designer (PSD). PSD 

facilitates the design of peptide arrays and peptide microarrays, providing tools for interactive 

peptide library design and graphical array layout. 

1.1 Installation  

PSA is natively supported on Windows and Mac OS X platforms, thus the software is able to run with 

high performance and native look. Installation of PSA requires rights of a system administrator. 

Hardware Requirement 

Minimum hardware: 1.5 GHz Processor, 1GB RAM. 

Recommended hardware: 2.0 GHz Dual-Core or faster Processor, 2 GB or more RAM. 

Windows Platforms 

PSA works on Windows XP, Windows 7, and Windows 8. Simply run the PSA setup. If the current 

Windows account is not an administrator, the user will be asked to input an administrative account 

and its password. 

Mac OS X platforms 

The software runs on Mac OS X 10.7 and 10.8. Unzip the package and double-click on the .pkg file to 

launch the installer. During the installation the user will be prompted to provide a system 

ŀŘƳƛƴƛǎǘǊŀǘƻǊΩǎ ŀŎŎƻǳƴǘ ŀƴŘ ǇŀǎǎǿƻǊŘΦ ¦Ǉƻƴ ŎƻƳǇƭŜǘƛƻƴΣ t{! ƛǎ ƛƴǎǘŀƭƭŜŘ ƛƴ ǘƘŜ 

/Applications/PepSlide/Analyzer folder. 
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1.2 Product A ctivation  

After installing PSA on Windows, the user needs to activate PSA with a trial serial number obtained 

from the software provider or its distributors. This enables the use of PSA with full functionality for 

30 days for free. Please refer to the product activation steps in Section 6. The trial time for PSA on 

Mac OS X platforms is handled automatically, thus the user does not need this step. 

When the free trial time has expired, the user can continue using PSA by purchasing a perpetual 

license or a term license from the software provider or its distributors. Upon the purchase, the user 

receives a serial number and uses it to activate the license. These steps are described in Section 6. 

1.3 Concepts 

In the remaining of this manual, the term array is used to mean both array and microarray, unless 

otherwise stated. 

The diagram of a typical peptide array analyzed by PepSlide® is outlined in Figure 1.  

 

Figure 1: Peptide Array Diagram. 
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A spot represents a single peptide spot located in one cell on the array. It can also be a control spot 

made of e.g. a known epitope. In the diagram, the spots are drawn as circles for the explanation 

purpose. Depending on the peptide array synthesizer, they may have rectangular or circular shape, 

as images of some actual spots shown in Figure 2. 

A spot family (SF) consists of spots generated from the same source. For peptide arrays an SF can be 

a peptide library or a control. A block is a group of spots located next to each other, just like its 

definition in GAL files. The distinction between a block (contains only spots and their annotation) and 

an SF (a peptide library and may consist of multiple blocks) enables a convenient use of GAL files. 

A marker control is a group of control spots arranged on either the same row or the same column of 

the array. It is used for the purpose of marking or orientation. A background control is used for the 

background correction during the data quantification. Its elements are virtual spots, i.e. neither 

peptide spot nor control spots, being used solely for defining the image regions from which the signal 

for background values is obtained. 

1.4 Peptide Array Data Analysis  

A PSA analysis project, including the analysis results and the paths to the input data, can be saved to 

a PepSlide® Analyzer file (*.psa) and reopened with the Project menu. Typical tasks of peptide array 

data analysis include: 

1. Quantification of array data 

¶ Load the scanned images and the array. 

¶ Align the array to the images. 

¶ Quantify the array data. 

2. Analysis of peptide libraries to select peptides of interest. 

3. Discovery of parameters influencing the study and their relation with data mining tools. 

The following sections explain how to do these tasks with PSA. 

2 Preparation  of Array  Data 

2.1 Loading Data 

Two input data are required for analyzing a peptide array: 

¶ Scanned images of the array in the TIFF format. PSA supports 8-bit or 16-bit grayscale images 

or 24-bit color images. For the best image quality 16-bit grayscale TIFFs are recommended.  

¶ The array design:  Either a GAL file (*.gal) or a PepSlide® Designer file (*.psf). 
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The input data is loaded as follows: 

¶ Images: Choose the Images > Open Image menu. For grayscale images, select either the Red 

channel or the Green channel to display the signal of each image. 

¶ Array design: Choose the Arrays > Open Array menu. 

All the image editing and data quantification tasks can be handled in the Imaging sheet. After being 

loaded, the images and the array are shown in the graphical canvas on the right side of this sheet. To 

obtain an appropriate view, the user can use the Zoom In and Zoom Out buttons on the toolbar or 

select a predefined zoom level in the Zoom combo-box. Alternatively, an arbitrary value can be 

entered directly into this combo-box. A control panel is located on the left side of the Imaging sheet. 

It shows properties of the image and selected objects in the array, in addition to options for image 

processing and data quantification tasks.  

If the array file is of PSF format, spots are grouped into Spot Families (SF). To view the information 

about an SF, first activate the Spot Family tab in the Design Information section of the Imaging sheet, 

and then click on the SF in the canvas. 

In case the array file is of GAL format, the software shows properties of a GAL block in the Block tab, 

which is located next to the Spot Family tab. When the Block tab is activated, the user can select a 

block, align it by moving and rotating, and quantify its spots. 

The information about a peptide spot, such as its unique position on the array and the sequence of 

amino acids, can be viewed similarly: First activate the Spot tab and then click on that spot. Within 

each spot, the spotted region is bounded by a dashed rectangle or circle depending on peptide array 

synthesizer. During the array alignment, the user will reallocate the array such that the spotted 

regions as close to the spots in the images as possible. 

  

(a) Rectangular Spot (b) Circular Spot 

Figure 2: Spot Images in PepSlide® Analyzer. 
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2.2 Editing Images  

Aligning arrays can be difficult if the spot visibility in the image is poor. This may be due to low signal 

intensities or noise of the image. In the Imaging sheet > Image Processing section > Pixels tab, the 

user can find utilities to improve the spot visibility. 

Adjustment of Brightness and Contrast 

Adjusting brightness and contrast can make the spots more visible for the array alignment.  When 

the Contrast check-box is selected and the Automatic Enhancement option is chosen, PSA examines 

the image data and adjust the pixel intensity values such that spots are as visible as possible. 

Brightness and contrast can also be manually adjusted, either by setting an arbitrary valid value 

directly in the combo-box or using the up/down control to change one unit. The valid range of 

brightness and contrast values for manual adjustment is [-99, 99]. 

Noise Filtering 

Noise in the loaded image(s) can be reduced by selecting the Noise Filtering check-box. 

Inversing 

An array image can be converted to a negative image by selecting the Inversion check-box. 

2.3 Rotating Images and Arrays  

PSA supports a comprehensive set of tools for rotating images and arrays. These tools are located in 

the Imaging sheet > Image Processing section > Rotation tab. 

To rotate the images, select the Image tab to display options as shown in Figure 3(a). One can flip the 

images and/or rotate them at angles of 90°, 180°, or 270°. 

If the array slightly deviates from the images at a small angle, it is recommended that the array (i.e. 

related SFs or blocks) be rotated, since image rotation may change the image data. To do that, select 

the Array tab to display parameters as shown in Figure 3(b). Selected SFs or blocks can then be 

rotated at an arbitrary angle in clockwise or counterclockwise direction, with a rotation center: 

¶ Global: the top-left of the image. 

¶ Local: the top-left of each SF and block. 
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(a) Rotating an image 

 

(b) Rotating an array 

Figure 3: Rotation of Images and Arrays. 

2.4 Aligning Arrays  

Before aligning ǘƘŜ ŀǊǊŀȅΣ ǘƘŜ ǳǎŜǊ Ƴŀȅ ƴŜŜŘ ǘƻ ŀŘƧǳǎǘ ǘƘŜ ƛƳŀƎŜǎΩ ŎƻƴǘǊŀǎǘ and brightness to make 

the spots more visible. In addition, the rotation of the images or the array may be necessary. 

If a PSF array file is loaded, first select the spot family (SF) containing the spots and then adjust the 

{CΩǎ Ǉƻǎƛǘƛƻƴ so that the spotted regions match their counterpart on the image.  Please note that one 

cannot move or rotate spots; instead this is done by means of the SF containing them. Therefore, in 

the Imaging sheet > Design Information section, the Spot Family tab must be activated. 

¶ Selecting SFs 

o Use Ctrl-A to select all SFs in the array.  

o To select individual SFs, click on the respective SF in the canvas. Hold down the Ctrl key 

for selecting multiple SFs simultaneously. 

¶ Moving SFs: Click on the selection and drag it to the desired position.  

When a GAL file is loaded, blocks can be selected, moved, and rotated like SFs. Please remember to 

activate the Block tab before using functions on blocks. 

The aligned array file can be saved with Ctrl-S or the Arrays > Save menu. It can be saved to another 

array file using the Arrays > Save Array As menu. 
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2.5 Adjusting Spot and Grid Size 

In addition to reallocating SFs or blocks, the user may 

ƴŜŜŘ ǘƻ ŀŘƧǳǎǘ ǘƘŜ ǎǇƻǘǎΩ ŘƛŀƳŜǘŜǊ ƻǊ ǘƘŜ ŘƛǎǘŀƴŎŜ 

between them, so that the spots and their spotted 

regions in the array fit their counterpart in the 

image(s). 

These parameters can be changed in the Imaging 

sheet > Design Information section > Configuration 

tab. The software reads ǘƘŜ ǎǇƻǘΩǎ ǎǇŜŎƛŦƛŎŀǘƛƻƴ from 

the array file and displays the corresponding settings.  

 

Figure 4: Circular Spot Size. 

 

Figure 5: Rectangular Spot Size. 

 

Figure 4 shows the spot diameter and the 

distance between them for circular spots. On the 

other hand, Figure 5 displays the settings for 

rectangular spots. These parameters can be 

changed permanently when the user saves the 

array file. 

3 Quantification  of Array  Data 

3.1 Quantifying  Array  Data 

The user needs to activate the Imaging sheet to perform the array data quantification. 

¶ Right-click at a point within the image but outside any SF or block. Choose Image Processing 

(entire array) to quantify all spots of the array. 

¶ To quantify selected SFs or blocks, right-click on the selection and choose Image Processing. 

For each spot in the array, the median and the mean of its raw, background, and foreground values 

in each channel (Red and/or Green) are calculated.  Raw represents the intensity value of the spotΩs 

signal. Background is the estimated value of the signal caused by non-specific binding. The value of 

interest is foreground; it is computed by subtracting the background from the raw value. 
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In the Imaging sheet, the user can view the spots and their quantified data simultaneously (Figure 6). 

The image region corresponding to the selected spot and its neighbors are displayed in the Spot 

Image widget. In addition, selecting a spot in the array highlights its quantified data in the table and 

vice versa. Please remember that in the Imaging sheet > Design Information section, the Spot tab 

must be activated for browsing spots and their data. 

 

Figure 6: Quantified Results. 

The user can ŀƭǎƻ ōǊƻǿǎŜ ǘƘŜ ǎǇƻǘǎΩ quantified data in the Imaging Results sheet, which shows only 

the table of quantified data and the Spot Image widget. In both Imaging and Imaging Results sheets, 

the user can export the quantified data to a CSV file for further analysis. 

Aggregating results of replicas 

When a peptide is replicated the software also provides the intensity value of the peptide calculated 

by aggregating signals from its replicated spots. If e.g. P1 and P2 are the replicas of a peptide P, then 

the quantified results include the intensity values for P, in addition to those for P1 and P2. Taking the 

raw median value of P for example, it is the median value of signals from both P1 and P2 spots, which 

cannot be calculated based on the median values of P1 and P2.  

This provides the user with an additional view to the replicated data. To control whether the 

aggregated data is calculated and shown, use the Aggregate results of replicas check-box. 
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Customizing the Quantified Data 

Click the Configurations menu and choose Imaging Result Values to show the setup dialog. Here, the 

user can add or remove values to be calculated during the data quantification. 

3.2 Change of Intensity Values  

During the array alignment, the user may have adjusted the contrast and/or the brightness of the 

ƛƳŀƎŜǎ ǘƻ ƳŀƪŜ ǘƘŜ ǎǇƻǘǎ ǾƛǎƛōƭŜΦ ¢Ƙƛǎ ŎƘŀƴƎŜǎ ǘƘŜ ƛƳŀƎŜǎΩ ǎƛƎƴŀƭ and alters the analysis results. It is 

recommended that the original image data be used for the quantification. Therefore, by default the 

quantification pǊƻŎŜŘǳǊŜ ǳǎŜǎ ǘƘŜ ƻǊƛƎƛƴŀƭ ƛƳŀƎŜΩǎ ǎƛƎƴŀƭ, i.e. it excludes changes ƳŀŘŜ ǘƻ ǘƘŜ ƛƳŀƎŜΩǎ 

signal due to inversion, noise filtering, or the adjustment of contrast and/or brightness. This option 

can be intentionally changed as follows. In the Imaging sheet > Image Processing section > 

Quantification tab, select the Included option below the /ƘŀƴƎŜ ƻŦ ǘƘŜ ƛƳŀƎŜǎΩ ƛƴǘŜƴǎƛǘȅ ǾŀƭǳŜ label.  

To use the original image data for the data quantitation again, select the Excluded option. Please 

note that when the this option is chosen, the Spot Image widgets in the Imaging, Imaging Results, 

and Peptide Library Analysis sheets show ǘƘŜ ǎǇƻǘΩǎ ŎƻǳƴǘŜǊǇŀǊǘ ƛƳŀƎŜ using ǘƘŜ ƻǊƛƎƛƴŀƭ ƛƳŀƎŜΩǎ 

signalΣ ŜǾŜƴ ǘƘƻǳƎƘ ǘƘŜ ƛƳŀƎŜΩǎ ŎƻƴǘǊŀǎǘ ƻǊ ōǊƛƎƘǘƴŜǎǎ Ƙŀǎ ōŜŜƴ changed. 

3.3 Spot Detection Methods  

In the Imaging sheet > Image Processing section > Quantification tab, the Spot Detection Method 

defines how the raw and background values of a spot are calculated. 

¶ Fixed-Spot: The software uses the signal in the spotted region to compute the raw value. The 

background value is calculated from the signal of the remaining region within the spot. This is 

the default method. It is recommended if the spots in the images look consistent and match 

well with the spotted regions in the array. 

¶ Other methods: The software combines the known information about the spotted region 

with the detected signals within each spot. It then flexibly separates the region consisting of 

signals for the raw value from the one for the background value. 

The default method for calculating the background value is called Local Method; it uses only the 

ǎǇƻǘΩǎ ǎƛƎƴŀƭΦ .ȅ ƳŜŀƴǎ ƻŦ ōŀŎƪƎǊƻǳƴŘ ŎƻƴǘǊƻƭǎΣ ǘƘŜ ǳǎŜǊ Ŏŀƴ ƘŀǾŜ ōŀŎƪƎǊƻǳƴŘ ǾŀƭǳŜǎ ǳǎƛƴƎ ǘƘŜ ǎƛƎƴŀƭ 

from other regions of the image. Background correction methods can be selected in the Imaging 

sheet > Image Processing section > Quantification tab. 
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3.4 Background Correction using Background Controls  

Instead of having the background values locally calculated as explained in Section 3.3, the user can 

use background controls to explicitly specify image regions from which the background values are 

calculated. One may choose to have a global background value for the entire array using a 

background control as follows. 

¶ Right-click at a point in the image where the signal may represent the background for the 

spots. Choose Create Background Control. Specify the shape and the number of spots. 

¶ Perform the data quantification. All spots in the array now have the same background value 

which is obtained from the background control. ²Ŝ Ŏŀƭƭ ǘƘŀǘ ŀƴ άassociationέ ōŜǘǿŜŜƴ ǘƘŜ 

SFs and the background control. 

 

Figure 7: Associated Background Control. 

In addition to a global background value for the entire array, one can flexibly choose an individual 

background value for a spot family. This is done by creating a background control just for the SF and 

establishing the association between them. 

¶ Right-click on the SF to popup the context menu. Choose Background Control > Remove 

Association to release the SF from the first background control. 

¶ Right-click on the SF again and choose Background Control > Establish Association. Click on 

the background control with which one wants to associate this SF. One can check with which 

control an SF is associated using the Highlight Associated Control context-menu (Figure 7). 

For GAL files, having a global background value or an individual background value for a block can be 

done similarly; the user creates a background control for the blocks and associates them. 

Please note that the background correction method is automatically set to Background Controls after 

the creation of the first background control. In the Imaging sheet > Image Processing section > 

Quantification tab, the user can switch back to use the Local Method. 
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4 Analysis of Peptide Librar ies 

After having the peptide array data quantified, the user may want to examine it and select peptides 

of interest with respect to the peptide array application. E.g. if an antigen is translated into 

overlapping peptides for epitope mapping, the user may be interested in a list of peptides which 

represent an epitope. ¢Ƙƛǎ Ŏŀƴ ōŜ ŘƻƴŜ ŎƻƴǾŜƴƛŜƴǘƭȅ ǿƛǘƘ t{!Ωǎ ǇŜǇǘƛŘŜ ƭƛōǊŀǊȅ ŀƴŀƭȅǎƛǎ ǘƻƻƭǎΦ By 

referencing the quantified data to the peptide library design, which keeps ǘƘŜ ŀƴǘƛƎŜƴΩǎ ŀƳƛƴƻ ŀŎƛŘ 

sequence and the overlapping step, PSA is able to locate the peptides representing the epitope. 

The software supports analysis of peptide library of the following types: 

¶ Overlapping library: Overlapping peptides translated from a protein. 

¶ Random library: Peptides generated stochastically. 

¶ Substitution (also called permutation or positional scanning) library: Variants of a known 

peptide created by replacing its residues with other amino acids. 

As mentioned, PSA represents a peptide library as a spot family (SF). If the array file is of PSF format, 

the user simply selects the relevant spot families, right-clicks on the selection, and chooses Peptide 

Library Analysis. The results are shown in the Peptide Library Analysis sheet.  

Analysis of a peptide library cannot be performed with GAL files in the first place. However, the user 

can easily specify the peptide library design for related GAL blocks. The analysis can then be 

preceded as with SFs. These steps are detailed in Section 4.4. 

4.1 Overlapping Peptide Library  Analysis  

This analysis aims at selecting peptide spots with strong signals. It is also able to detect a consensus 

motif shared by overlapping peptides. 

A two-dimensional chart in the center of the sheet depicts the peptide spots (Figure 8). Their 

coordinates can be selected among the quantified intensity values. By moving the lower and upper 

threshold bars, the chart facilitates the selection of spots whose intensity values being within the two 

thresholds. Selected spots are then populated into the table below the chart. 

By clicking on a spot in the chart or selecting the corresponding row in the table, the user can view 

the spot information such as the peptide and its counterpart image. The information is shown in the 

Spot Details widget located on the right of the sheet. The chart, the table, and the Spot Details 

widget thus provide the user with different angles to look at the data of the peptide library.  
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Figure 8: Overlapping Peptide Library Analysis. 

The user can export the data in the table to a CSV file. The chart can also be saved to an image file. 

Identifying Consensus Motifs 

In the table below the chart, overlapping peptides sharing a consensus motif are highlighted with an 

individual color. In Figure 8, rows corresponding to these peptides are in grey. Among them, the one 

being selected for review is highlighted in blue; its information is shown in the Spot Details widget. 

 

Figure 9: Consensus Motif . 

Right-click on the highlight and choose 

Show Consensus Motif to view the 

information (Figure 9). Data in this 

dialog can be copied and pasted into 

other software, e.g. a word processing 

program. 

In the sample data package, the overlapping1 folder contains a test dataset for this analysis. 
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4.2 Random Peptide Library Analysis  

This analysis facilitates browsing and selecting peptide spots with strong signals for further 

optimization. Except for the detection of consensus motifs, the user interface and functions of this 

analysis (Figure 10) are the same as those in the analysis for overlapping peptide libraries. 

 

Figure 10: Random Peptide Library Analysis. 

In the sample data package, the random1 folder contains a test dataset for this analysis. 

4.3 Substitution Peptide Library Analysis  

Peptides of a substitution peptide library are created by replacing residues of a known peptide, the 

so-called parent peptide, with some other amino acids. The purpose of this analysis is thus to 

ŜȄŀƳƛƴŜ ŀƭƭ ǾŀǊƛŀƴǘǎ ƻŦ ǘƘŜ ǇŀǊŜƴǘ ǇŜǇǘƛŘŜ ŀƴŘ ǎŜƭŜŎǘ ǘƘƻǎŜ ƻŦ ǘƘŜ ǳǎŜǊΩǎ ƛƴǘŜǊŜǎǘΦ Figure 11 displays 

the analysis results of a substitution peptide library whose parent peptide is NYGKYE. 

The variants of the parent peptide and their intensity value are simultaneously shown in a three-

dimensional chart. Here, the (P)-Axis lists residues of the parent peptide and the (S)-Axis contains 

ŀƳƛƴƻ ŀŎƛŘǎ ŦƻǊ ǊŜǇƭŀŎƛƴƎΣ ǘƘǳǎ ŀ άǇƻƛƴǘέ ƛƴ ǘƘŜ όt{ύ-plane features a variant. The intensity value of a 

variant is represented by the height of the corresponding bar along the Z-Axis. The user can choose 

to evaluate another quantified value in the Z-Axis section in the left panel. The perspective of the 

chart can be changed by holding-down the left-button of the mouse and moving it. 
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Figure 11: Substitution Peptide Library Analysis. 

Spots are selected by entering the lower and/or upper threshold values in the Spots of Interest 

section in the left panel. The selection will be populated into the table below the chart. Similar to 

other analyses, the user can view information about a spot in the Spot Details widget. Selecting a 

spot in the table highlights its version in the chart and vice versa.  

The chart can be saved to an image file. In addition, the data in the chart and the table can be 

exported to a CSV file.  

 

Figure 12: Parent Peptide Spots. 

Quality Control with Parent 
Peptide Spots 

The user can choose to display only spots 

having the same amino acid sequence as 

those of the parent peptide. Since these spots 

are the same peptide, their intensity values 

should not be considerably different. This 

option is found in the Spots with Parent 

Peptide section in the left panel. 

In the sample data package, the substitution1 folder contains a test dataset for this analysis. 
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4.4 Peptide Library Analysis with GAL Files  

The user can conveniently use array files of GAL format, even for the analysis of peptide library. 

Whether the peptides of a peptide library (PL) are spotted into one block or different blocks, the user 

can easily reconstruct the PL and then analyze it as explained in the previous sections. The 

reconstruction can be done in two steps: 

¶ Specify a peptide library design for the blocks. This creates a PL consisting of these blocks. 

¶ If the GAL file does not contain ǘƘŜ ǇŜǇǘƛŘŜ ƛƴ ǘƘŜ ǎǇƻǘǎΩ L5Σ ƛmport the peptide mapping file. 

Each step is described in detail below. For reading convenience, we assume that an overlapping PL is 

being reconstructed. The procedure is the same for substitution and random peptide libraries.  

Specify a Peptide Library Design for GAL Blocks 

¶ Hold down the Ctrl key while clicking on the blocks to select them simultaneously.  

¶ Right-click on the selection and choose Type > Overlapping Peptide Library. 

¶ Enter the design of the peptide library (Figure 13) including the protein, the shift step, and 

the peptide length. 

 

Figure 13: Overlapping Peptide Library Design. 

An overlapping peptide library consisting of these blocks, represented by PSA as a spot family, has 

been created. The user can activate the Spot Family tab and review the information of the PL. 

Import the Peptide Mapping File 

Please note that this step is only necessary if the ǎǇƻǘǎΩ ID field in the GAL file does not contain the 

peptide yet, as illustrated in Figure 16(a). 
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¶ Activate the Spot Family tab to work on peptide libraries.  

¶ In the canvas, select the PL by clicking on one of its blocks. Right-click on the selection and 

choose Import Peptide Mapping File from the context menu (Figure 14). 

¶ Specify the linker which will be excluded from the peptides. Leave it blank if no linker is used. 

¶ Select the file which maps the peptides of the PL to their spot ID in the blocks.  

 

Spot_ID Peptide 

1 CxMGPGIAAVLLSLAVA 

2 CxGIAAVLLSLAVALAR 

3 CxAVLLSLAVALARVPA 

Χ  

10  CxPPNWHVPEASDVTIQ  

Χ 

Figure 14: Import the Mapping File. Figure 15: The Peptide Mapping File. 

The peptide mapping file is a Tab-delimited text file or CSV file. It has two columns; the first one 

contains the ID of the peptides in the blocks and the second column contains the peptides. The first 

line of the file is reserved for the column headers and will be skipped. An exaƳǇƭŜ ƻŦ ǘƘŜ ŦƛƭŜΩǎ 

content is shown in Figure 15. In this example, the linker is Cx. 

  

(a) Spot ID from the Original GAL File (b) Spot ID with the Peptide 

Figure 16: Assigning the Peptide to a Spot. 

After importing the peptide mapping file, activate the Spot tab in the Design Information section. 

Now, the user can view the peptide in the ID field when clicking on a spot in the canvas, as illustrated 

in Figure 16(b). The overlapping peptide library has been completely reconstructed and can be 

analyzed as described in Sections 4.1 to 4.3. Please note that saving the GAL file also keeps the 

information about the peptide library design.   

In the sample data package, the overlapping3 folder contains a test dataset for this function. 
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5 Statistical Data Mining Tools  

Statistical data mining tools assist the user to discover useful information from complex datasets. For 

example, in this study1 the researchers were able to distinguish the patients before and after the 

medical treatment with the assistance of Principal Component Analysis and Hierarchical Clustering 

Analysis. These statistical analysis tools are available in PepSlide® Analyzer. The user can use them in 

the following applications, including but not limited to: 

Statistical Analysis Tool Possible Applications 

Principal Component Analysis 

(PCA) 

¶ Find parameters or variables that most likely determine 

the variance of the data. 

¶ Search for views that are likely to separate the data and 

show the variance direction. 

¶ Reduce the dimension of the dataset and identify new 

influential variables. 

Hierarchical Clustering Analysis 

(HC) 

¶ Find possible association or relation between inputs 

and/or outputs of the data.  

¶ Identify similarity between features and/or samples. 

K-Means Clustering Analysis ¶ Classify data with similarity or association into groups. 

 

By combining the above statistical analyses, the users have powerful tools to look into their data and 

to determine influential factors of their study. 

Notes on data source: The data from this work2 is used to illustrate the analysis results in this section. 

 

                                                           
1
 Le Moyec, et al. (2005): Serum 

1
H-nuclear magnetic spectroscopy followed by principal component analysis and hierarchical 

cluster analysis to demonstrate effects of statins on hyperlipidemic patients. NMR Biomed., 18: 421–429. 

2
 Schröder et al. (2010): Dual-color proteomic profiling of complex samples with a microarray of 810 cancer-related antibodies, 

Molecular & Cellular Proteomics 9(6): 1271. 
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5.1 The Input Dataset  

This section explains how to prepare and load the dataset for the Principal Component Analysis and 

the Hierarchical Clustering Analysis. An input dataset can be: 

¶ compiled from a list of PepSlide® Analyzer files (*.psa); 

¶ compiled from a list of GenePix Result files (*.gpr); 

¶ a CSV file exported from a dataset. 

The PSA and GPR files must contain the quantified array data for the same set of features (for 

peptide arrays a feature can be a peptide). In other words, they all based on a template array file. In 

the dataset, the samples (experimentsύ ŀǊŜ ǘƘŜ ŦƛƭŜǎΩ ƴŀƳŜΦ ¢ƘŜ ŦŜŀǘǳǊŜǎΩ ǾŀƭǳŜ ƛǎ ǎŜƭŜŎǘŜŘ ŀƳƻƴƎ ǘƘŜ 

list of quantified intensity values, e.g. Red Foreground Mean, in the Evaluation Parameter section of 

the analysis sheet. 

 

Figure 17: The Input Dataset 

After being loaded, the dataset is shown in the table at the bottom of the analysis sheet (Figure 17). 

In the case the dataset is compiled from PSA or GPR files, the loaded data contains only the selected 

quantified values and thus has small size. Therefore, if the user plans to analyze the dataset again, 

export it to a CSV file. It is much faster to load this CSV file than the whole set of PSA or GPR files in 

each analysis. 

5.2 Principal Component Analysis  

Click the Analysis menu and choose Principal Component Analysis to activate the PCA sheet. 

¶ Click the Load Data button to load the input dataset. Please refer to Section 5.1 for the 

preparation of the dataset. 

¶ Specify the evaluation parameter if necessary. 

¶ Choose to reduce the dimension of features or samples. 

¶ Click the Start PCA button.  
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Figure 18: Principal Component Analysis. 

The projection of the input dataset to the three components that most probably describe the 

variance of the data is depicted in the PCA chart (Figure 18).  The user can change the view angle to 

the data by holding-down the left-button of the mouse and moving it. 

 

Figure 19:  Projection on Two Principal Components 

The chart is three-dimensional initially and 

can be switched to two-dimensional views 

(Figure 19). 

The eigenvalues and the eigenvectors are 

shown in the table. They can be exported to 

a CSV file. In addition, PCA charts can be 

saved to an image file using the Export to 

Image context-menu. 

 

In the sample data package, the schroeder2010 folder contains a test dataset for this analysis. 
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5.3 Hierarchical Clustering  

Click the Analysis menu and choose Hierarchical Clustering to activate the HC sheet. 

¶ Click the Load Data button to load the input dataset. Please refer to Section 5.1 for the 

preparation of the dataset. 

¶ Specify the evaluation parameter if necessary. 

¶ Choose to construct the clustering tree for features, or samples, or both. 

¶ Select the desired Distance Metric and Algorithm Type. 

¶ Click the Start HC button to begin analysis. 

 

Figure 20: Hierarchical Clustering Analysis. 

The clustering tree(s) are then constructed. The values in the dataset, each represents a feature in 

one sample, are graphically represented by means of a heat map. 

The clustering trees with the heat map can be saved to an image file using the Export to Image 

context-menu. 

In the sample data package, the schroeder2010 folder contains a test dataset for this analysis. 
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5.4 K-Means Clustering  

After analyzing overlapping or random peptide libraries, the user can use K-means Clustering to 

classify peptides into different groups based on their quantified intensity values.   

¶ Click the Analysis menu and choose K-Means Clustering to activate the setup dialog. 

¶ Enter the desired number of clusters, i.e. groups, and customize their color if necessary.  

¶ Click OK: TƘŜ ŎƘŀǊǘ ǘƘŜƴ ǎƘƻǿǎ ǎǇƻǘǎ ƘƛƎƘƭƛƎƘǘŜŘ ƛƴ ǘƘŜƛǊ ŎƭǳǎǘŜǊΩǎ ŎƻƭƻǊ (Figure 21).  

In the Clusters section in the left panel, select the cluster of interest. The table then shows only spots 

of that cluster.  

Data in the table can be exported to a CSV file. The chart can be saved to an image file. 

 

Figure 21: K-Means Clustering Analysis. 

In the sample data package, the dataset in the random1 folder can be used to test this analysis. 
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6 Product A ctivation  

The product activation requires an internet connection. The user needs to have a serial number 

obtained from the software provider or its distributors. 

(1) In the Evaluation Time Has Expired dialog, click the Next button. 

 

Figure 22: Starting the Product Activation. 

(2) Enter the serial number and the licensee information in the Product Activation dialog. Click Next. 

 

Figure 23: Entering the licensee information. 
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(3) If the internet connection is ready, click the Activate button and wait for the activation to finish.  

 

Figure 24:  Product Activation in Progress. 

Please check the internet connection in the case PSA could not reach the activation server. If 

your system uses a proxy server to connect, specify it using the Proxy setting link. Otherwise, 

contact the software provider for support. 

(4) A completion message is shown to the user when the product is successfully activated. Click Next 

to use PSA immediately or End to use it later. 

 

Figure 25: Completion of the Product Activation. 

Please note that licenses can be reviewed, or renewed in the case of a term license, by clicking 

on the Help menu and choosing License Information.  
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7 Sample Datasets 

The sample data package consists of sample datasets that can be used to get familiar with PepSlide® 

Analyzer software.  

The overlapping1, random1, and substitution1 folders contain the data of peptide arrays whose array 

file is of PSF format. The overlapping3 folder also contains peptide array data, but the array file is 

prepared in the GAL format. The user can perform data quantification (Sections 2 and Section 3) as 

well as analysis of peptide library (Section 4) on these datasets. 

A dataset for testing data mining tools (Section 5) is stored in the schroeder2010 folder. 

Further information of the datasets is described below. 

overlapping1 

The peptide array consists of overlapping peptide libraries. The signals are recorded in a 16-bit 

grayscale TIFF image. 

Reference to Analysis Functions: Section 4.1. 

random1 

The peptide array consists of random peptide libraries. The arrayΩǎ ǎŎŀƴƴŜŘ ƛƳŀƎŜ is a 24-bit color 

TIFF file, having the control signals in the green channel and the peptide signals in the red channel.  

Reference to Analysis Functions: Section 4.2 and Section 5.4. 

substitution1 

The peptide array contains a substitution peptide library. The signals are recorded in an 8-bit 

grayscale TIFF image. 

Reference to Analysis Functions: Section 4.3. 
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overlapping3 

This peptide array contains an overlapping peptide library. Since the array file is of GAL format, the 

user can try creating a peptide library for GAL blocks with this dataset.  

In this folder, file overlapping3_design.txt stores the design information of the peptide library, while 

file PeptideMappingFile.txt contains the peptide mapping data. The signals are recorded in a 16-bit 

grayscale TIFF image. 

Reference to Analysis Functions: Section 4.4 and Section 4.1. 

schroeder2010 

This folder contains a dataset compiled from this work3. The original GenePix Result (GPR) files can 

be downloaded here.  

The user can test the Hierarchical Clustering Analysis and Principal Component Analysis with this 

dataset. In this folder, file schroeder2010.csv stores the Log Ratio (549/649) values of the GPR files. 

The same data is stored in file schroeder2010_filtered.csv, excepted that positional controls (starting 

with ps_) have been filtered out. 

Reference to Analysis Functions: Section 5.2 and Section 5.3. 

  

                                                           
3
 Schröder et al. (2010): Dual-color proteomic profiling of complex samples with a microarray of 810 cancer-related antibodies, 

Molecular & Cellular Proteomics 9(6): 1271. 

http://www.ebi.ac.uk/arrayexpress/files/E-MEXP-3006/E-MEXP-3006.raw.1.zip
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8 Customer License Agreement  

Customer License Agreement for User of PepSlide® Analyzer. 

PEPSLIDE ANALYZER IS THE PROPERTY OF SICASYS SOFTWARE GMBH (SICASYS).  THE USE OF THIS 

SOFTWARE IS GOVERNED BY THE TERMS AND CONDITIONS OF THE AGREEMENT SET FORTH BELOW. 

¢I9 ¢9wa ά{hC¢²!w9έ ![{h Lb/[¦59{ w9[!¢95 5h/¦a9b¢!¢Lhb ό²I9¢I9w Lb twLb¢ hw 

ELECTRONIC FORM) AND ANY UPDATES OR UPGRADES OF THE SOFTWARE PROVIDED BY SICASYS.  

BY INSTALLING THE SOFTWARE, AND/OR BY USING THE SOFTWARE, YOU AGREE TO BE BOUND BY 

THE TERMS AND CONDITIONS OF THIS SOFTWARE LICENSE AGREEMENT.  

License. SICASYS grants to you (USER) a non-exclusive, non-transferable license of use for the 

SOFTWARE on a number of computers stated in the license contract. A separate license is required 

for use on any additional computer. 

Copy Restriction. The SOFTWARE may not be copied either in full or part by USER, with the exception 

of making copy for security or backup purpose. Copies must include all copyright and trademark 

notices. 

Use Restrictions. This SOFTWARE is licensed to USER for internal use only. USER shall not (and shall 

not allow any third party to): 

(i) decompile, disassemble, reverse engineer or attempt to reconstruct, identify or discover any 
source code, underlying ideas, underlying user interface techniques or algorithms of the 
SOFTWARE by any means whatever, or disclose any of the foregoing;  

(ii) modify, incorporate into or with other software, or create a derivative work of any part of 
the SOFTWARE; 

(iii) attempt to circumvent any user limits, or other license, timing or use restrictions that are 
built into the SOFTWARE. 

Ownership of the SOFTWARE. SICASYS retains all titles of ownership, all ownership rights, and all 

intellectual property rights of the SOFTWARE. SICASYS reserves all rights not expressly granted to 

USER. 

Termination. SICASYS may terminate this Agreement immediately if USER breaches any provision. 

Upon notice of termination by SICASYS, all rights granted to USER under this Agreement will 

immediately terminate, and USER shall cease using the SOFTWARE and return or destroy all copies of 

the SOFTWARE. 

Limited Warranty and Disclaimer. USER is aware of the fact that technical errors in the program in 

accordance with the accompanying documentation cannot be excluded. If USER claims deviations in 

the program from the specification/description, USER has the right to request a fix, patch, work-

around, or replacement of the SOFTWARE that does not meet such limited warranty. If a rectification 

of the errors is not possible or if such rectification is not successful, USER has the right to request a 

rescission of the contract, where USER must destroy all copies of the SOFTWARE. 
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EXCEPT AS EXPRESSLY SET FORTH ABOVE, NO OTHER WARRANTIES OR CONDITIONS, EITHER 

EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, ARE MADE BY SICASYS WITH RESPECT TO THE 

SOFTWARE AND THE ACCOMPANYING DOCUMENTATION, AND SICASYS EXPRESSLY DISCLAIMS ALL 

WARRANTIES AND CONDITIONS NOT EXPRESSLY STATED HEREIN, INCLUDING BUT NOT LIMITED TO 

THE IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, NONINFRINGEMENT, AND 

FITNESS FOR A PARTICULAR PURPOSE. SICASYS DO NOT WARRANT THAT THE FUNCTIONS 

/hb¢!Lb95 Lb ¢I9 {hC¢²!w9 ²L[[ a99¢ ¦{9wΩ{ w9v¦Lw9a9b¢{Σ .9 ¦bLb¢9wwUPTED OR ERROR 

FREE, OR THAT ALL DEFECTS IN THE PROGRAM WILL BE CORRECTED. USER ASSUMES THE ENTIRE 

RISK AS TO THE RESULTS AND PERFORMANCE OF THE SOFTWARE. 

Limitation of Liability. IN NO EVENT SHALL SICASYS BE LIABLE FOR ANY INDIRECT, SPECIAL, 

CONSEQUENTIAL OR INCIDENTAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, 

DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTIONS, LOSS OF BUSINESS 

INFORMATION, OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE 

SOFTWARE, EVEN IF SICASYS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 

FURTHER, IN NO EVENT SHALL SICASYS BE LIABLE FOR ANY DIRECT DAMAGES ARISING OUT OF 

¦{9wΩ{ ¦{9 hC ¢I9 {hC¢²!w9Φ Lb bh 9±9b¢ ²L[[ {L/!{¸{ .9 [L!.[9 ¢h ¦{9w Chw 5!a!D9{ Lb !b 

AMOUNT GREATER THAN THE FEES PAID FOR THE USE OF THE SOFTWARE. 

Intellectual Property Right Infringement. If a claim alleging infringement of an intellectual property 

right arises concerning the SOFTWARE (including but not limited to patent, trade secret, copyright or 

trademark rights), SICASYS in its sole discretion may elect to defend or settle such claim, and/or 

terminate this Agreement and all rights to use the SOFTWARE, and require the return or destruction 

of the SOFTWARE, with a refund of the fees paid for use of the SOFTWARE less a reasonable 

allowance for use and shipping. 

Miscellaneous. This Agreement is the entire agreement between USER and SICASYS with respect to 

the license to the SOFTWARE, and supersedes any previous oral or written communications or 

documents (including, if USER is obtaining an update, any agreement that may have been included 

with the initial version of the Software). This Agreement is governed by the laws of Germany. If any 

provision, or portion thereof, of this Agreement is found to be invalid or unenforceable, it will be 

enforced to the extent permissible and the remainder of this Agreement will remain in full force and 

ŜŦŦŜŎǘΦ CŀƛƭǳǊŜ ǘƻ ǇǊƻǎŜŎǳǘŜ ŀ ǇŀǊǘȅΩǎ ǊƛƎƘǘǎ ǿƛǘƘ ǊŜǎǇŜŎǘ ǘƻ ŀ ŘŜŦŀǳƭǘ ƘŜǊŜǳƴŘŜǊ ǿƛƭƭ ƴƻǘ ŎƻƴǎǘƛǘǳǘŜ ŀ 

waiver of the right to enforce rights with respect to the same or any other breach. 
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9 Index  

A 

activate · 2, 22, 23 

aligning · 6 

block · 6 

spot family · 6 

analysis of peptide array data · 3 

analysis of peptide library · 3, 11 

GAL files · 11, 15 

overlapping peptide library · 11 

random peptide library · 13 

substitution peptide library · 13 

array · 2 

array · 2 

microarray · 2 

peptide array diagram · 2 

B 

background control · 10 

association · 10 

background correction · 9, 10 

background control · 10 

for a block · 10 

for a spot family · 10 

global background value · 10 

Local Method · 9, 10 

background value · 7 

block · 3, 4 

brightness · 5, 6, 9 

C 

consensus motif · 11, 12 

contrast · 5, 6, 9 

automatic enhancement · 5 

control · 3 

background control · 3 

marker control · 3 

D 

data mining tools · 3, 17, 18 

F 

file 

*.gal · 3 

*.psa · 3 

*.psf · 3 

GAL · 3 

PepSlide® Analyzer · 3 

PepSlide® Designer · 3 

foreground value · 7 

H 

hardware requirement · 1 

HC · 17 

Hierarchical Clustering Analysis · 17, 20 

input dataset · 18 

I 

Installation · 1 

Mac OS X platforms · 1 

Windows Platforms · 1 

inversion · 5 

K 

K-Means Clustering Analysis · 17, 21 

L 

license · 2 

Customer License Agreement · 26 

perpetual license · 2 

term license · 2 

N 

noise filtering · 5 

P 

PCA · 17 

PepSlide® · 1 

PepSlide® Analyzer · 1 

PepSlide® Designer · 1 

PSA · 1 

PSD · 1 

peptide library · 3, 15 



9 | Index 

PepSlide® Analyzer ¦ǎŜǊΩǎ DǳƛŘŜ Version 1.4 Page 29 

design · 15 

overlapping · 11 

permutation · 11 

positional scanning · 11 

random · 11 

substitution · 11 

Principal Component Analysis · 17, 18 

input dataset · 18 

Q 

quantification · 3, 7, 9, 10 

change of intensity values · 9 

R 

raw value · 7 

replicas · 8 

aggregate results · 8 

rotating · 5 

array (spot families or blocks) · 5, 6 

images · 5, 6 

S 

sample data package · 12, 13, 14, 16, 19, 20, 21, 24 

selecting · 6 

block · 6 

spot family · 6 

serial number · 2, 22 

SF · 3 

spot · 3, 4 

control spot · 3 

distance between spots · 7 

peptide spot · 3 

size · 7 

spot detection method · 9 

Fixed-Spot · 9 

other · 9 

spot family · 3, 4 

spotted region · 4, 6, 9 

Z 

zoom · 4 

 


